Cloud39 - Outage
Incident Report for Medius
Resolved
Access to AP Automation is restored for all customers.
Posted Mar 18, 2024 - 22:39 UTC
Investigating
Customers on Cloud39 may have problems connecting to AP Automation.
Posted Mar 18, 2024 - 21:58 UTC
This incident affected: AP Automation (Cloud39).