Cloud39 - Outage
Incident Report for Medius
Resolved
Access to AP Automation is restored for all customers.
Posted Mar 27, 2024 - 11:10 UTC
Investigating
Customers on Cloud39 may have problems connecting to AP Automation. We are investigating the issue.
Posted Mar 27, 2024 - 10:35 UTC
This incident affected: AP Automation (Cloud39).