Cloud21 - Outage
Incident Report for Medius
Resolved
Access to AP Automation is restored for all customers.
Posted Mar 26, 2024 - 21:08 UTC
Investigating
Customers on Cloud21 may have problems connecting to AP Automation.
Posted Mar 26, 2024 - 20:40 UTC
This incident affected: AP Automation (Cloud21).